macOS High Sierra

Apple released macOS 10.13 (High Sierra) on September 25th, 2017 via the App Store.

This new version provides stability, compatibility and security improvements.

ITS recommends NOT updating at this time until all standard desktop software can be fully tested.

Information on Sophos for 10.13: KB0018684 (ITR logon required)

Software compatibility list for High Sierra: Roaring Apps (macOS)

highsierrapic.png

Click here for Apple's High Sierra webpage

Sierra's hardware requirements

  • MacBook (Late 2009 or newer)
  • MacBook Pro (Mid 2010 or newer)
  • MacBook Air (Late 2010 or newer)
  • Mac mini (Mid 2010 or newer)
  • iMac (Late 2009 or newer)
  • Mac Pro (Mid 2010 or newer)